Monday, November 9, 2015

Chrome Browser drops support for certain plug-ins

As of September 1, 2015, Google Chrome will stop supporting an older version of the plug-in architecture known as NPAPI.

The following are the most popular NPAPI plug-ins used in Google Chrome:

Google Talk
Google Earth

The adoption rate of these plug-ins has dropped over the years, so it is unlikely you will be affected. If you find that a Website you visit stops working, try using another browser such as Firefox until the sites move away from using the deprecated, and potentially insecure NPAPI architecture.

More information is available on the Official Chromium Blog.